XPressME Integration Kit

フォーラム

i is undefined がでて編集できなくなる

ようこそ フォーラム バグ報告と提案 i is undefined がでて編集できなくなる

このトピックには4件の返信が含まれ、2人の参加者がいます。8 年、 3 ヶ月前 匿名 さんが最後の更新を行いました。

5件の投稿を表示中 - 1 - 5件目 (全5件中)
  • 投稿者
    投稿
  • #2653

    匿名

    すでに書かれている投稿を

    投稿>編集

    で一覧を出して、各投稿の編集ボタンを押す

    「ビジュアル」「HTML」のタブがあるのですが

    「ビジュアル」を押した後「HTML」を押すと

    i is undefined

    のエラーが出ます。

    これが原因なのかはわかりませんが、このエラーが出るときは

    「ビジュアル」タブをクリックして「ビジュアル」モードにした後は

    テキストの編集も画像のアップロードもできません。

    サーバによっては一時的にできる場合も合ったのですが

    現在は、上記問題で編集できなくなってしまいました。

    原因は、何が考えられるでしょうか?

    #3160

    toemon
    キーマスター

    k-miyaさんこんにちは

    i is undefined

    のエラーが出ます。

    i is undefined?これだけ?エラー箇所のファイル名やライン番号とかもなしって

    うーん何だろこれ? javascript側で吐いてるエラーかなっと思ったりするんですが、謎です。

    ビジュアルエディタは標準のtinyMCEでしょうか?

    とりあえずこれだけでは何ともわからないので、システム情報の提示(全文)をお願いいたします。

    あと、お使いのブラウザの情報もお願いいたします。

    また、お使いのブラウザを変えて(IE,FireFox,Chrome…など)も同じ状況なのか確認願います。

    以上、よろしくお願いいたします。

    #3161

    匿名

    説明が足りませんでしたね。

    JavaScriptのエラーになります

    エラー内容は


    エラー: i is undefined

    ソースファイル: http://hostname/modules/blog/wp-includes/js/tinymce/wp-tinymce.php?c=1&ver=327-1235

    行: 2


    システム情報は


    ******** システム情報********

    SERVER: Apache/2.2.3 (CentOS)

    PHP Version: 5.1.6

    libxml Version: 2.6.26

    MySQL Version: 5.0.22

    XOOPS Version: XOOPS Cube Legacy 2.1.8

    XPressME Version: 2.3

    WordPress Version: 2.9.2

    WP DB Version: 12329

    safemode: OFF

    register_globals: OFF

    magic_quotes_gpc: OFF

    XML extension: ON

    default memory_limit: 128M

    change memory_limit: 128M

    post_max_size: 128M

    upload_max_filesize: 20M

    display_errors: OFF

    MB extension: ON

    mbstring.language: Japanese

    mbstring.encoding_translation: ON

    mbstring.internal_encoding: UTF-8

    mbstring.http_input: pass

    mbstring.http_output: pass

    mbstring.detect_order: auto

    mbstring.substitute_character: none

    mbstring.func_overload: OFF

    ******** XPressMEがXOOPSより取得した設定値********

    XOOPS_ROOT_PATH: OK

    XOOPS_TRUST_PATH: OK

    XOOPS_URL: OK

    XOOPS_SALT: OK

    XOOPS_DB_HOST: OK

    XOOPS_DB_USER: OK

    XOOPS_DB_PASS: OK

    XOOPS_DB_NAME: OK

    XOOPS_DB_PREFIX: OK

    ******** WordPressで使用中のプラグイン********

    Google Maps Anywhere: Version 1.2.4: (http://wppluginsj.sourceforge.jp/googlemaps-anywhere/)

    Plugin for XPressME: Version 1.0: (http://ja.xpressme.info)

    ******** ブロックステータス********

    最近の記事内容: OK

    最近の記事: OK

    人気記事リスト: OK

    ページ: OK

    最近のコメント: OK

    サイドバー: OK

    検索: OK

    カレンダー: OK

    アーカイブ: OK

    投稿者: OK

    タグクラウド: OK

    カテゴリー: OK

    メタ情報: OK

    ウィジェット: OK

    拡張ブロック: OK

    ******** ブロックオプション********

    最近の記事内容 : blog||10|0|100||||0|0|0

    新着情報 : blog|db:blog_recent_posts_list_block.html|5|1|7||||0

    人気記事リスト : blog||10|0||||0

    ページ : blog||post_title|asc||||0|0|none||1||

    最近のコメント : blog||10|30|||0

    サイドバー :

    検索 : blog||18

    カレンダー : blog||#DB0000|#004D99

    アーカイブ : blog||monthly|0|1|0

    投稿者 : blog||0|1|0|1

    タグクラウド : blog||8|22|pt|45|flat|name|ASC||

    カテゴリー : blog|db:blog_category_block.html|すべて|ID|ASC|0|0|1|1|||1|0

    メタ情報 : blog||1|1|1|1|1|1|1|1

    ウィジェット : blog||1|

    拡張ブロック : blog||

    加盟店ご紹介 : blog|db:blog_recent_posts_list_block.html|5|1|7||||0

    ******** グループ権限********

    : (module_admin) : administrator(No) :

    登録ユーザ : (module_admin) : inhibit register(No) :

    確認用グループ : (module_read) : inhibit register(No) :

    ブログ管理者 : (module_admin) : administrator(No) :

    ******** ユーザーメタ情報********

    ユーザーメタキーは正常です

    ******** Blog ブログ統計********

    カテゴリー数: 3

    記事数: 7

    投稿者数: 1


    エラーが出た後、「ビジュアル」タブを押した後

    「HTML」タブを押してもエラーは出ませんでした。

    最初の一回目だけ出るようです。

    また、ブラウザの種類によらず、Firefox IE Chrome Safariでも同じ現象でした。

    #3162

    toemon
    キーマスター

    一度、Google Maps Anywhere: Version 1.2.4プラグインを外してお試しください。

    すこし古い情報ですが、WordPress日本語Codexにある「ビジュアルエディタやエディタのツールバーの問題解決には、次のことを試す 」を試してみてください。

    #3163

    匿名

    原因は、Google Maps Anywhere: Version 1.2.4でした。

    Google Maps Anywhere自体が問題ではなく

    このモジュールで使用するタグが、投稿内に書かれている場合のみ

    上記JavaScriptエラーが出るようです。

    無事解決できました

    ありがとうございます。

5件の投稿を表示中 - 1 - 5件目 (全5件中)

このトピックに返信するにはログインが必要です。