XPressME Integration Kit

フォーラム

Analyzer for XC との相性?

ようこそ フォーラム 開発版 Analyzer for XC との相性?

このトピックには3件の返信が含まれ、2人の参加者がいます。8 年、 6 ヶ月前 toemon さんが最後の更新を行いました。

4件の投稿を表示中 - 1 - 4件目 (全4件中)
  • 投稿者
    投稿
  • #2581

    匿名

    毎度お世話さまです。

    toemonさんに伺う話ではないのかも知れませんが、使用していて?っと

    思った事があったのでこちらに書かせて頂きます。

    XPressMEを使用しているサイトで、Analyzer for XCというアクセス解析

    モジュールを使用しています。

    このモジュールでサイトアクセス数を記録するようにしているのですが、

    XPressME1へのアクセスはカウントされていたのですが、XPressME2では

    アクセス記録も保存されず、カウントされなくなってしまいました。

    解決策があれば教えて頂きたく、よろしくお願いします。

    #2734

    toemon
    キーマスター

    自分も藤右衛門の親父のサイトでXPressME Ver2.00 RC1 と Analyzer for XC (0.44)を使ってますので、久しぶりにログを確認してみました。(^^;)

    それによると、ログは取れているみたいです。

    Analyzer for XCの「ログ記録ブロック」の表示対象としてXPressMEモジュールが対象になっていますか? といいたいところなんですが

    Analyzer for XC の新しいバージョンのREADMEを見てみますと

    Ver0.5以降、基本的にログ記録ブロックは表示させる必要はありません。(プリロードで記録しています)

    とのことですので、プリロードでの記録確認は、藤右衛門の親父のサイトで確認は先ほどVer0.44からVer0.51アップデートしたばかりなので、もう少し後になります。

    一応ローカルテスト環境でlocalhostを「記録しないHOST」から外してのチェックではOKでした。

    #2735

    匿名

    ありがとうございます。

    結論からもお伝えすると解決しました!!

    試した事を記載しておきます。

    1、プリロード形式だよね?の確認。

       >ログ記録ブロックは使っていない(プリロード版である)事を確認

    2、RC版にアップグレード

       >カウントNG

    3、試しにアクセスカウンターの表示ブロックのアクセス権をXPressME用に

      作成したグループに権限を付与

       >カウントOK

    という結果になりました。

    ※XPressME1の時は、登録ユーザー全員に書込OKとしていたのですが、

     登録ユーザーの中でも書込OK/NGを切り分ける為にグループを

     新設して対応していたのですが、それが仇となってしまってました。

    解決のヒントを頂き、ありがとうございました。

    今後ともよろしくお願いします。

    #2736

    toemon
    キーマスター

    解決できてよかったです。

    ずぼらな親父は、こんなことでもないと確認しませんから,(^^;)

    とりあえず、Analyzer for XCとの相性確認問題なしが判っただけでも拾い物です。

    それに、Analyzer for XCのバージョンアップの機会を作っていただき感謝です。

4件の投稿を表示中 - 1 - 4件目 (全4件中)

このトピックに返信するにはログインが必要です。