XPressME Integration Kit

フォーラム

投稿後にFatal errorが表示されるように

永らくありがとうございました フォーラム 使い方全般 投稿後にFatal errorが表示されるように

  • このトピックには2件の返信、2人の参加者があり、最後に匿名により12年、 3ヶ月前に更新されました。
3件の投稿を表示中 - 1 - 3件目 (全3件中)
  • 投稿者
    投稿
  • #2632
    匿名
    ゲスト

    toemon様

    いつもお世話になっております。

    以前、xoops cubeサイト(xpressME)の引越しを行い、

    何とかデータの移行も完了することができました。

    (引越し前)

    hd_1.03(xcl 2.1.6)

    XPressME271-ver1.09

    PHP 5.2.11

    MySQL 4.0

    (引越し後)

    hd_1.04(xcl 2.1.7)

    XPressME_Integration_Kit_Ver2.1.4

    wordpress 2.8.6

    PHP 5.2.11

    MySQL 5.X

    そこで、久しぶりに記事投稿(既存の記事を編集・新規投稿)をしようと思いまして、

    「公開」・「更新」をクリックすると、以下のようなエラーが発生しました。

    Fatal error: Call to undefined function get_block_file_path() in /ドメイン/modules/news/wp-content/plugins/xpressme/include/xpress_common_functions.php on line 148

    エラーは出るのですが、記事やカテゴリ設定などは

    更新されています。

    このままでの問題はないのですが、少々気持ちが悪く…。

    ※ちなみに、引越しの際、カテゴリやタグは新たに設定したいと思いまして、

     以下のsplデータはバックアップを取りませんでした。

     ・a13519_news_terms

     ・a13519_news_term_relationships

     ・a13519_news_term_taxonomy

    何かお気づきの点がございましたら、ご指摘いただければ幸いです。

    どうぞよろしくお願い申し上げます。

    #3046
    toemon
    キーマスター

    ky982339さんこんにちは

    この部分は、新規投稿や新規コメント、投稿修正などを行った際に、ブロックのキャッシュを更新している部分です。

    エラー内容が、get_block_file_path()が見つからないということですので、

    この関数が定義されている、XPressMEモジュール/include/xpress_block_render.phpが正しくアップロードされているか確認お願いいたします。

    #3047
    匿名
    ゲスト

    toemon様

    レスが遅くなり、誠に申し訳ありませんでした。

    いまさらインフルエンザにかかりまして・・・。

    しばらくPCから離れておりました。

    /include/xpress_block_render.php

    はアップロードされていました。

    新たにディレクトリを作成し、再度引越し作業を行い再現したところ、

    問題なく記事の更新ができるようになりました。

    ん~どこかでファイルがうまくアップされていなかったのでしょうか。

    ただ、なんとかうまく引越しできたようなのでよかったです。

    初歩的なミスのようで・・・申し訳ございませんでした。

    toemon様もインフルには気をつけください。

    ありがとうございました!

3件の投稿を表示中 - 1 - 3件目 (全3件中)
  • フォーラム「使い方全般」には新規投稿および返信を追加できません。