XPressME Integration Kit

フォーラム

アップデートしたらログイン状態が保持できなくなった

永らくありがとうございました フォーラム インストール アップデートしたらログイン状態が保持できなくなった

  • このトピックには2件の返信、2人の参加者があり、最後に匿名により13年、 2ヶ月前に更新されました。
3件の投稿を表示中 - 1 - 3件目 (全3件中)
  • 投稿者
    投稿
  • #2596
    匿名
    ゲスト

    こんにちは、以前も、元のサイトで質問させていただき、お世話になりました。

    この度、XPressME271-Ver1.09からXPressME Integration Kit2.02へバージョンアップました。こちらのサイトの説明どおりに行い、おおむね成功した、と思ったのですが、そのバージョンアップをやってから、Xoops自体のログイン状態が保持できなくなってしまい、2~3分?ほど時間が経つと&別の頁に飛んだりすると、すぐにログアウト状態になってしまうようになりました。

    ブラウザはFireFox3.0.11とIE6で、同じ症状を確認しました。

    キャッシュを消してみたり、クッキーを消してみたりとかしたんですが…

    クッキーの有効期限は「XPress」とついたものは「セッション終了時」となっております。

    他のモジュールをいじっているときも、別の頁に移ったり、トップ頁に戻ろうとしたらすぐにログアウト状態になってしまいました。

    Protectorを入れているので、そちらを停止してみたりとか、また全般設定でセッションのタイムアウト時間を長くしてみたりとか、色々やってはみたのですが改善されません。

    XPressMEのバージョンアップと関係あるのかどうかもさっぱり分からないのですが、ただ、バージョンアップをきっかけとして、そういう状態になってしまったのは確かなので、こちらで質問させていただこうかと…

    何か、解決策についてアドバイスがいただければ助かります。

    よろしくお願いいたします。

    末尾に、XPressMEのシステム情報をコピペしておきます。

    SERVER::Apache

    PHP Version::5.2.5

    MySQL Version::5.1.22-rc

    XOOPS Version::XOOPS Cube Legacy 2.1.6

    XPressME Version::2.02

    WordPress Version::2.8.1

    WP DB Version::11548

    safemode:ON

    register_globals:ON

    magic_quotes_gpc:OFF

    XML extension:ON

    memory_limit:90M

    post_max_size:32M

    upload_max_filesize:32M

    display_errors:ON

    MB extension:ON

    mbstring.language:Japanese

    mbstring.encoding_translation:OFF

    mbstring.internal_encoding:UTF-8

    mbstring.http_input:pass

    mbstring.http_output:pass

    mbstring.detect_order:auto

    mbstring.substitute_character:none

    mbstring.func_overload:OFF

    #2800
    toemon
    キーマスター

    fujimiさんお久しぶりです。

    たぶん、php.iniの設定でregister_globalsがONに設定してあるためで、

    wordpressではセキュリティー対策のためregister_globalsがONの場合、$GLOBALS[]の一部をunsetしています。

    その結果、セッションIDが変わってしまい、XOOPS上ではログアウト状態になってしまいます。

    通常は、セキュリティーの問題からregister_globalsはOFFとしてあると思うのですが、事情があってONにしなければならないのであれば、

    wp-settings.php の46行目あたりの

    wp_unregister_GLOBALS();

    の部分をコメントアウト

    // wp_unregister_GLOBALS();

    してみてください。

    但し、これは WordPress側のコードですので WordPressのアップグレードを行うたびに変更が必要となるので、あまりお勧めしません。

    やはりregister_globalsは可能な限りOFFにしておくことをお勧めします。

    ちなみに、XPressME Ver1.Xでログアウト状態にならないのは、この部分を

    if(!defined(“XOOPS_ROOT_PATH”))

    wp_unregister_GLOBALS();

    に変更してwp_unregister_GLOBALS()を実行しないようにしている為です。

    #2801
    匿名
    ゲスト

    toemonさん、お返事ありがとうございます。

    本当にいつもお世話になっております。

    register_globalsの問題とは!

    いつもProtectorにうるさく言われているにも関わらず、よく分からなくて放置しておりました。

    Xreaサーバーなんですが、デフォルトでonになってしまっているんですよね。

    早速.htaccessに「php_value register_globals 0」を追加してみましたら、無事ログイン状態が保持されるようになりました!

    ありがとうございました。

3件の投稿を表示中 - 1 - 3件目 (全3件中)
  • フォーラム「インストール」には新規投稿および返信を追加できません。