XPressME Integration Kit

Codex

モジュール作成(WP2.7 以降)

注意事項(Notes)

  1. XpressME Integration KitはそれだけではXOOPSモジュールとして機能しません。
    (XpressME Integration Kit doesn’t function only by it as XOOPS module.)
  2. 対象となるWordPressのバージョンは2.7以上となります。(それ以下のバージョンでの動作確認は行っておりません。)
    (Being able to integrate by this is WordPress version 2.7 or more. )

必要なファイルのダウンロード

  1. XPressME Integration Kit のダウンロード(Download of XPressME Integration Kit)
    ダウンロードページからXPressME Integration Kitをダウンロードします。
    (XPressME Integration Kit is downloaded on the download page. )



    ダウンロードしたファイルの構成は以下のようになっています。
    (The composition of the downloaded file is as follows. )

    xp_intrgration_kit

  2. WordPressのダウンロード(Download of WordPress)
    WordPress.org(あるいはWordPress日本語などのローカライズサイト)からWordPressをダウンロードします。
    (WordPress is downloaded from WordPress.org Or, localize site of WordPress Japanese etc. )



    ダウンロードしたファイルの構成は以下のようになっています。(WordPress2.7の場合)
    (The composition of the downloaded file is as follows for WordPress2.7. )

    wordpress_file

モジュール作成(Making XPressME module for XOOPS)

  1. 作業用のフォルダーを作成します。(フォルダー名はxpressなどのモジュールの名前にします)
    注意 使用可能な文字は「英数字」「アンダースコア( _ )」のみ
    (The work directory is made. The directory name is made the module name such as ‘xpress’. )
    Only “Alphanumeric character” and “Underscore ( _ )” : can be used.
  2. XPressME Integration Kitのファイルを 手順1.で作成した作業用フォルダーにコピーします。
    (The file of  XPressME Integration Kit is copied onto the work directory of step 1. )
  3. WordPressのファイルを 手順1.で作成した作業用フォルダーにコピーします。
    (The file of  WordPress is copied onto the work directory of step 1. )

make_xp_module