XPressME Integration Kit

ブログ

XPressME Integration Kit Ver2.4.8リリース

XPressME Integration Kit Ver2.4.8をリリースします。

Ver2.4.8では2.4.7のバグ修正が行われました。

XLC2.2にてwp_version_compare()が読み込まれない (thx shinjuou)

Fatal error: Call to a member function exists() (thx shinjou)

コメント / トラックバック 8 件

  1. shinjou より:

    お世話になっております。
    ブログの記事を書いていましたらバージョンアップのお知らせが表示されましたので、自動更新させていただきました。

    いつも本当にありがとうございます。

  2. bbbb より:

    WordPress3.5jp+XPressME Integration Kit Ver2.4.8にしたらXOOPSのサイト自体が真っ白になりました。
    XOOPSの設定でPHPデバグONにしてみても何も表示されずでWordpressを3.4にしたら治りました。
    これはWordPress3.5には対応できてないということでしょうか?

    XC Legacyバージョン : XOOPS Cube Legacy 2.2.1
    サーバー : Apache/2.2.14 (Ubuntu)
    PHPバージョン : 5.2.10-2ubuntu6.10
    MySQLのバージョン : 5.1.66-0ubuntu0.10.04.3

    PHPの設定
    セーフモード : オフ
    最大実行時間 : 30 sec.
    メモリ制限 : -1b
    表示エラー : オフ
    ショートオープンタグ : オン
    ファイルをアップロード : オン
    マジッククオート : オフ
    グローバル変数の登録 : オフ
    出力バッファリング : オフ
    open_basedir : オフ
    url_fopenを許可 : オフ
    DOMの拡張 : はい
    exifの拡張 : はい
    gettextの拡張 : はい
    JSONの拡張 : はい
    XMLを有効 : はい
    Curlの拡張 : はい
    Zlibを有効 : はい
    Soapの拡張 : はい
    Mbstringを有効 : はい
    Iconvの利用 : はい
    GDの拡張 : はい
    GD Version: 2.0 or higher
    GDの拡張 Image create Truecolor

  3. toemon より:

    bbbbさんこんばんわ
    テストサイト
    ******** System infomation********
    SERVER: Apache/2.2.15 (CentOS)
    PHP Version: 5.3.3
    libxml Version: 2.7.6
    MySQL Version: 5.1.61
    XOOPS Version: XOOPS Cube Legacy 2.2.1
    XPressME Version: 2.48
    WordPress Version: 3.5
    WP DB Version: 22441
    のほうではXPressME2.4.8+WordPress3.5の環境では問題なく動作しています。

    詳しく試してないので不明ですが 
    http://wpdocs.sourceforge.jp/%E3%83%86%E3%83%B3%E3%83%97%E3%83%AC%E3%83%BC%E3%83%88:%E3%82%B5%E3%83%BC%E3%83%90%E8%A6%81%E4%BB%B6 
    にも書かれてますように、
    WordPress3.2以降はPHPバージョン5.2.4以下では動作保障できません(動作チェックしません)ということですので、
    Wordpressを3.4まではたまたま動作していたということかもしれません。
    WordPressのアップグレードは、自動更新で行っているのでしょうか?
    自動更新の場合はサーバー要件が見たされていない場合は、バージョンアップできないはずなんですが・・・
    いずれにせよ、今後WordPressの新しいバージョンをお使いになるつもりであれば、PHPのバージョンアップをお考えになったほうがよろしいかと思います。

  4. bbbb より:

    あら、今まで正常だったので5.2.10-2というのは5.2.10みたいに思ってましたが5.2.1みたいな意味なんですかね
    PHPは5.3から動かないスクリプトが多いのでわざわざダウングレードして今のVerに至ってるわけですがそうであれば最新にするのも検討してみます。

  5. toemon より:

    すみません、うっかりしてました 5.2.10-2 > 5.2.4 ですよね。 
    いちど、 PHPの表示エラー : オフ -> ON でエラー表示されないか, PHPエラーログになにか記録がないか確認いただけると原因が特定できるかもしれません。

    また、問題解決にあたり、既存の構成に影響を与えないよう、モジュール名(ディレクトリ名)を変えて問題の構成でインストールして再現してみるのもよいかもしれません。

  6. heiji より:

    toemon さん、こんばんは。

    すみません。半月ほど前にフォーラムのほうに投稿させていただいたのですが、ご覧になっていただけておりますでしょうか?

    煽るつもりなど毛頭ございませんが、いつもすぐにお返事いただけていたのに、他の方の投稿にもレスが付いておらず、こちらのコメントのほうにはレスが付いておりましたので、もしかしたらフォーラムに障害が発生していて、toemon さんに投稿の通知がいかなくなっているかもしれないと思い、こちらに書き込ませていただきました。

    もちろん、お忙しいとか、調査中とかでありましたら、ご都合を優先いただいて結構です。

    ご迷惑な書き込みになってしまいましたら申し訳ございません。

  7. toemon より:

    heiji さんこんにちは
    すみません、wp-admin/update-core.phpの直リンク のフォーラムのほうはきちんと認識しております。 
    お正月にとおもっていたのですが、町内会の引継ぎやら 、開発用パソコンの再インストールやら、そして主にぐーたら生活のため、遅々としておりました。
    wp-admin/update-core.phpの直リンクについては、あまり必要性を感じなかったので
    当初からまったく確認しておりませんでした、ちょいデバッカーで確認してみます。

  8. heiji より:

    toemonさん、お返事ありがとうございます。

    結果として煽ってしまったようで申し訳ありません。
    フォーラムのほうに障害が発生していたわけではないのですね。

    ログインし直せばよいので、制約条件であれば無理に直していただかなくても大丈夫ですが、簡単に直るのであればひと手間楽ができるようになると思いまして。

    遅くなりましたが、昨年は本当にいろいろお世話になりました。
    本年もまたよろしくお願い致します。 m(_o_)m

コメントをどうぞ