XPressME Integration Kit

ようこそ

Please refer to here for a little explanation in English.

XPressME Integration Kitのサイトへようこそ

XPressMEのご利用ありがとうございます。

XPressMEの配布は、藤右衛門の親父で配布しておりましたが、XPressME Integration Kit (XPressME Ver2.X以降)の専用サイトとしてこのサイトを立ち上げさせていただきました。

XPressME Integration Kitに関する、お問合せ、ご要望、バグ報告などがございましたら、XPressME Integration Kitフォーラムに投稿いただけますようお願いいたします。

特徴

XPressMEはWordPressをXOOPSのモジュールにしたものです。

XPressME Ver1.XではWordPressのXOOPSモジュール化にあたりWordPressのコードの一部を変更するなどの処置をおこなっていましたが、

XpressME Ver2.Xにおいては、統合に必要な処理をプラグインやpluggable-overrideを利用することで、WordPressのオリジナルコードを変更することなくモジュール化を実現しています。

このため、WordPressの新しいバージョンがリリースされた場合でも、XPressMEとは無関係に自動アップデートなどのWordPressアップデート作業を行うことが出来ます。・・・そのはずです。 (^^;

このような性質から、XPressME Ver2.X以降は、XPressME Integration Kit という形でWordPressのコードを含まない形式で配布させていただくことにいたしました。 ご面倒でしょうが、ご理解のほど宜しくお願いいたします。

XPressME Integration Kitの最新版はダウンロードサイトよりダウンロード出来ます。

尚、XPressME Integration Kitを使ったXPressMEモジュールの作成方法については『モジュール作成とインストール』を参照いただけますようお願いいたします。

どうぞ、XPressME Ver2.Xをお楽しみください。

XPressME Integration Kit スタートガイド

XPressME Integration Kit をはじめて利用するための情報が必要でしたら、以下をご覧ください。

WordPressをはじめて利用するための情報が必要でしたら、以下をご覧ください。

動作環境

  • 日本語をお使いの場合 UTF-8での利用となります。
  • 互換表 (PHP,MySQLバージョンについては「テンプレート:サーバー要件」を参考にしました。
WordPress XPressME PHP MySQL
ME2.0.11 2.1以上 4.2以上 3.23.23以上
2.1 4.0以上 *1
2.5 4.4以上
2.9 2.2以上 4.12以上
3.0 2.3.8以上
3.2 5.2.4以上 5.0.15以上
3.4 2.4.4以上
4.0 2.5.3以上
4.5 2.5.4以上

*1   確認されている制限事項:

MySQL 4.0.x は UTF-8 をサポートしていないため、UTF-8 のブログで MySQL 4.0.x を使用した場合に日本語によるサイト内検索やソートが正しく機能しないことがあります。WordPress 日本語版をお使いの場合は MySQL 4.1以上の使用を推奨します。

統合の確認を行っているWordPressバージョン

  • WordPress 2.70以上
  • WordPress 3.0から実現されたmultiblogへの対応はXPressME Integration Kit Ver2.3Xからになります。
  • WordPress 2.90以上への対応はXPressME Integration Kit Ver2.2Xからになります。
  • WordPress3.4.0以上への対応はXPressME Integration Kit Ver2.4.4からになります。
  • WordPressME2.0.11への対応はXPressME Integration Kit Ver2.1Xからになります。
  • WordPressME2.1.3の場合はWordPress自体に、こちらの処理が必要となります。

XOOPS動作環境

推奨XOOPSモジュール